
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.ricentral.com/content/tncms/live/" />
<meta name="keywords" content="town council, kevin maloney, candidate, finance, politics, economics, student, funding, high school, kimberly page" />
<meta name="news_keywords" content="town council, kevin maloney, candidate, finance, politics, economics, student, funding, high school, kimberly page" />
<meta name="description" content="atrubia@ricentral.com" />
<meta name="author" content="ALEX TRUBIA" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/2bae7990-f437-11e4-9bc1-cb9219ef6fad.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Local candidates talk issues at HS forum" />
<meta property="og:description" content="atrubia@ricentral.com" />
<meta property="og:site_name" content="RICentral.com" />
<meta property="og:section" content="Local News" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.5cfe8d2b6e902b79c4710d15b491c631.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/live/global/resources/styles/site.css?_dc=1506427214"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Droid+Serif:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:300,400,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/nk_standard_times\/news\/local_news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"ALEX TRUBIA","id":"f29f8acc-1d25-11eb-9fdf-bb342737072b","app":"editorial"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":382},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-5261583-37"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/13855/cc.js?ns=_cc13855" id="LOTCC_13855"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc13855.add('tp', 'TNNW');
		_cc13855.add('act', ' User Login');
		_cc13855.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc13855.bcp();
</script>

<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["town council","kevin maloney","candidate","finance","politics","economics","student","funding","high school","kimberly page"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.834cbe7aa25c4d789bfb4c362348b677.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '23317403/SRITopBannerHome';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [728, 90]).addSize([992, 0], [[728, 90], [970, 90], [970, 250]]).addSize([1200, 0], [[728, 90], [970, 90], [970, 250]]).build();
                gptAdSlots['ad-774800'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250]], 'ad-774800').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '23317403/SRIBoxHome';
            
                gptAdSlots['ad-774870'] = googletag.defineSlot(adUnit, [[300, 250], [300, 600]], 'ad-774870').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"description":"Sign up for our daily email newsletters to be informed every day!","heading_tag":"h4","require_user_account":"1","signup_lists_only":"","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","bg_color":"","text_color":"inherit","list_ids":"","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"603041"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '23317403/SRIBottomBox';
            
                gptAdSlots['ad-774871'] = googletag.defineSlot(adUnit, [[300, 250], [300, 600]], 'ad-774871').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/ads/impressions.js?_dc=1604421336.temp"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/ads/traffic.js?_dc=1604381729"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/ads/settings.js?_dc=1519927372"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Local candidates talk issues at HS forum | Local News | ricentral.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.ricentral.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Local candidates talk issues at HS forum | Local News | ricentral.com" href="http://www.ricentral.com/search/?f=rss&amp;t=article&amp;c=nk_standard_times/news/local_news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <script type="text/javascript">
           jQuery(document).ready(function(){
           
            $('#tncms-block-373026 .list-inline').append('<li><a href="/site/rss/" title="RSS" class="btn btn-md btn-link rss"><span class="fa fa-rss"></span></a></li>');
            $('#tncms-block-373034 .list-inline').append('<li><a href="/site/rss/" title="RSS" class="btn btn-md btn-link rss"><span class="fa fa-rss"></span></a></li>');  
            $('.add-arrows .headline-list li span').prepend('<span class="fa fa-arrow-circle-right"></span> ');
            $('#topbar-col-one-nav_menu a.dropdown-toggle').prepend('<span class="fa fa-arrow-circle-down"></span> ');
            
            
          
            
           });
           
           
           
</script>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-f29f8acc-1d25-11eb-9fdf-bb342737072b section-nk-standard-timessection-newssection-local-news type-article infinity-disabled" data-authors='[]' data-path="/nk_standard_times/news/local_news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.ricentral.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fnk_standard_times%2Fnews%2Flocal_news&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=ALEX+TRUBIA&tncms.asset.id=f29f8acc-1d25-11eb-9fdf-bb342737072b&tncms.asset.app=editorial&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.system.render_time=382&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-5261583-37&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.ricentral.com/users/admin/contribute/article/?assetid=f29f8acc-1d25-11eb-9fdf-bb342737072b&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.ricentral.com/users/admin/contribute/article/?from_section=/nk_standard_times/news/local_news"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.ricentral.com/tncms/admin/editorial-asset/?edit=f29f8acc-1d25-11eb-9fdf-bb342737072b"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-603143" class="tncms-block"></div><div id="tncms-block-603141" class="tncms-block"><section id="block-603141" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-603141" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-603141" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-lg form-control">
        <input id="site-search-603141-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-603141-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-603141-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-603141').submit();
        return false;
    });

    $('#site-search-603141').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-603141 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-603141 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-603141-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-603142" class="tncms-block padding-top"><div id="user-controls-603142" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.ricentral.com/users/signup/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.ricentral.com/users/login/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.ricentral.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-603142').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ricentral.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ricentral.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ricentral.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-603142').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.ricentral.com/users/logout/" id="user-logout-form-603142"><input type="hidden" name="referer_url" value="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/nk_standard_times/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/state/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/news/national_and_world/"  class="nav-link tnt-section-national-and-world-news">National and World News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/nk_standard_times/sports/local_sports/"  class="nav-link tnt-section-local-sports">Local Sports </a>
                                </li><li>
                                    <a href="/sports/college"  class="nav-link tnt-section-college-sports">College Sports </a>
                                </li><li>
                                    <a href="/sports/pro_sports"  class="nav-link tnt-section-pro-sports">Pro Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/letters_to_the_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/arts_entertainment/"  class="nav-link tnt-section-timeout">Timeout</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/nk_standard_times/multimedia/photos/"  class="nav-link tnt-section-photos">Photos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/special_sections/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                                </li><li>
                                    <a href="http://local.ricentral.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-local-guide">Local Guide</a>
                                </li><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="http://games.ricentral.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-games">Games</a>
                                </li><li>
                                    <a href="/stock_market/"  class="nav-link tnt-section-stocks">Stocks</a>
                                </li><li>
                                    <a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://oceanstatemarketplace.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="http://southernrhodeislandnewspapers.adperfect.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-place-ad">Place Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://www.legacy.com/obituaries/ricentral/"  target="_blank" rel="noopener" class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-publications"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Publications</span>
                </a><ul id="topbar-col-one-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-chariho-times"  href="/chariho_times/" >
                    <span class="nav-label">Chariho Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-coventry-courier"  href="/coventry_courier/" >
                    <span class="nav-label">Coventry Courier</span>
                </a></li><li>
                <a class="nav-link  tnt-section-east-greenwich-pendulum"  href="/east_greenwich_pendulum/" >
                    <span class="nav-label">East Greenwich Pendulum</span>
                </a></li><li>
                <a class="nav-link  tnt-section-kent-county-daily-times"  href="/kent_county_daily_times/" >
                    <span class="nav-label">Kent County Daily Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-narragansett-times"  href="/narragansett_times/" >
                    <span class="nav-label">Narragansett Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-nk-standard-times"  href="/nk_standard_times/" >
                    <span class="nav-label">NK Standard Times</span>
                </a></li></ul></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-603145" class="tncms-block"><div id="user-controls-603145" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.ricentral.com/users/signup/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.ricentral.com/users/login/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.ricentral.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-603145').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.ricentral.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.ricentral.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.ricentral.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-603145').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.ricentral.com/users/logout/" id="user-logout-form-603145"><input type="hidden" name="referer_url" value="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-603146" class="tncms-block"><div class="follow-links-603146 pull-right">
    
    <section id="block-603146" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/srinewspapers/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/SRINewspapers" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.ricentral.com",
  "sameAs" : ["https://www.facebook.com/srinewspapers/","https://twitter.com/SRINewspapers"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-603139" class="tncms-block no-logo-margin"><section id="block-603139" class="block emphasis-h3   " ><div class="block"><a href="/nk_standard_times/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png?resize=200%2C36 200w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png?resize=300%2C54 300w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png?resize=400%2C72 400w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png?resize=540%2C98 540w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png?resize=750%2C136 750w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/4e54c4aa-0552-11e5-a8c1-23ebf8d69116.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-603140" class="tncms-block"><section id="block-603140" class="block emphasis-h3   text-shadow " >
    <div class="clearfix"></div>
    <div id="search-form-603140" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-603140" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg form-control">
        <input id="site-search-603140-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-603140-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-603140-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-603140').submit();
        return false;
    });

    $('#site-search-603140').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-603140 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-603140 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-603140-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-603147" class="tncms-block hidden-xs hidden-sm clearfix header-ad"><script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/23317403/SRIMiniBannerTop', [200, 90], 'div-gpt-ad-1448315453194-0').addService(googletag.pubads());
googletag.enableServices();
});
</script>
<!-- /23317403/SRIMiniBannerTop -->
<div id='div-gpt-ad-1448315453194-0' style='height:90px; width:200px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1448315453194-0'); });
</script>
</div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-603131" class="tncms-block"><section id="block-603131" class="block emphasis-h3   " ><div class="block"><a href="/nk_standard_times/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png?resize=200%2C19 200w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png?resize=300%2C29 300w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png?resize=400%2C38 400w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png?resize=540%2C52 540w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png?resize=750%2C72 750w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/901305fa-0552-11e5-9831-b78a68ee45e4.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-603132" class="tncms-block"><div id="weather-603132" class="weather-current size-nav pull-right">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=02879" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-cloudy"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">46&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="02879"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-603132 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Wakefield, RI
                                
                                 <small>(02879)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Sun and clouds mixed. High 46F. Winds NW at 10 to 15 mph..</p>
                            <h5>Tonight</h5>
                            <p>Clear skies. Low 31F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: November 3, 2020 @ 11:27 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=02879"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="/nk_standard_times/news/local_news/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state-news"  href="/news/state/" >
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national-and-world-news"  href="/news/national_and_world/" >
                    <span class="nav-label">National and World News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-sports"  href="/nk_standard_times/sports/local_sports/" >
                    <span class="nav-label">Local Sports </span>
                </a></li><li>
                <a class="nav-link  tnt-section-college-sports"  href="/sports/college" >
                    <span class="nav-label">College Sports </span>
                </a></li><li>
                <a class="nav-link  tnt-section-pro-sports"  href="/sports/pro_sports" >
                    <span class="nav-label">Pro Sports</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-letters-to-the-editor"  href="/letters_to_the_editor/" >
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-timeout"  href="/arts_entertainment/" >
                    <span class="nav-label">Timeout</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-multimedia"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Multimedia</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-photos"  href="/nk_standard_times/multimedia/photos/" >
                    <span class="nav-label">Photos</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-special-sections"  href="/special_sections/" >
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-guide"  href="http://local.ricentral.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Local Guide</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-games"  href="http://games.ricentral.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Games</span>
                </a></li><li>
                <a class="nav-link  tnt-section-stocks"  href="/stock_market/" >
                    <span class="nav-label">Stocks</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://oceanstatemarketplace.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-place-ad"  href="http://southernrhodeislandnewspapers.adperfect.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Place Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="http://www.legacy.com/obituaries/ricentral/"  target="_blank" rel="noopener">
                    <span class="nav-label">Obituaries</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-774800" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-774800" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-774800');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-f29f8acc-1d25-11eb-9fdf-bb342737072b" class="asset article-default"  data-url="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/2bae7990-f437-11e4-9bc1-cb9219ef6fad.jpg">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="ricentral.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" />
    <style>
                .asset-paging .direction {
                    color: #AAA;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.ricentral.com\/tncms\/search\/mlt\/?origin=f29f8acc-1d25-11eb-9fdf-bb342737072b&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-f29f8acc-1d25-11eb-9fdf-bb342737072b" class="asset-paging">
                <div id="paging-prev-f29f8acc-1d25-11eb-9fdf-bb342737072b" class="paging-link prev offset"></div>
                <div id="paging-next-f29f8acc-1d25-11eb-9fdf-bb342737072b" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Local candidates talk issues at HS forum
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-3bbf3f36-23b4-11e8-a905-5cb9017b3617-asset-f29f8acc-1d25-11eb-9fdf-bb342737072b" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.ricentral.com/users/profile/Alex%20Trubia">ALEX TRUBIA</a></span>
                
                    <div id="author-popup-3bbf3f36-23b4-11e8-a905-5cb9017b3617-asset-f29f8acc-1d25-11eb-9fdf-bb342737072b-content" class="hide">
                        <article class="clearfix card author popup-content card-author-3bbf3f36-23b4-11e8-a905-5cb9017b3617">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.ricentral.com/users/profile/Alex%20Trubia" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Alex Trubia"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://secure.gravatar.com/avatar/d61087778ddece8ac5bbf81ae4e43f3b?d=mm&r=g"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.ricentral.com/users/profile/Alex%20Trubia" rel="author" class="tnt-user-profile-link tnt-user-name">Alex Trubia</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:atrubia@ricentral.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                        <i class="fas tnt-envelope tnt-stack-1x tnt-inverse"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-3bbf3f36-23b4-11e8-a905-5cb9017b3617-asset-f29f8acc-1d25-11eb-9fdf-bb342737072b').popover({
                            content: $('#author-popup-3bbf3f36-23b4-11e8-a905-5cb9017b3617-asset-f29f8acc-1d25-11eb-9fdf-bb342737072b-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2020-11-02T14:15:00-05:00" class="tnt-date asset-date text-muted">
            Nov 2, 2020
        </time></li>
            <li class="hidden-print">
        <time datetime="2020-11-02T14:15:00-05:00" class="tnt-date asset-date text-muted">21 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-11-02T14:15:00-05:00">
    <meta itemprop="datePublished" content="2020-11-02T14:15:00-05:00">
    <meta itemprop="dateModified" content="2020-11-02T14:15:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked square"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-facebook-f tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Local%20candidates%20talk%20issues%20at%20HS%20forum&url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-twitter tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-whatsapp tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ricentral.com/tncms/asset/editorial/f29f8acc-1d25-11eb-9fdf-bb342737072b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BRICentral.com%5D%20Local%20candidates%20talk%20issues%20at%20HS%20forum&body=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-envelope tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="f29f8acc-1d25-11eb-9fdf-bb342737072b">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline square"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-facebook-f tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Local%20candidates%20talk%20issues%20at%20HS%20forum&url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-twitter tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-whatsapp tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ricentral.com/tncms/asset/editorial/f29f8acc-1d25-11eb-9fdf-bb342737072b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BRICentral.com%5D%20Local%20candidates%20talk%20issues%20at%20HS%20forum&body=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-envelope tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                        <i class="fas tnt-print tnt-stack-1x tnt-inverse"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f29f8acc-1d25-11eb-9fdf-bb342737072b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f29f8acc-1d25-11eb-9fdf-bb342737072b" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x tnt-inverse"></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f29f8acc-1d25-11eb-9fdf-bb342737072b" class="save-list-f29f8acc-1d25-11eb-9fdf-bb342737072b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f29f8acc-1d25-11eb-9fdf-bb342737072b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><a href="mailto:atrubia@ricentral.com">atrubia@ricentral.com</a></p><p>NORTH KINGSTOWN – Ahead of the upcoming general election, the North Kingstown School District continued its long-established tradition of hosting Candidates Day, a forum for high school students to ask questions of candidates running for local, state and national office. While the district traditionally holds the forum in the high school auditorium, this year’s event was pre-recorded and done virtually, due to COVID-19 restrictions on large gatherings.</p><p>The Candidates Day forum was overseen by Lawrence Verria, chair of the social studies department at the high school, with the help of students from the Democracy Program. Questions were selected from student submissions.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Every opposed candidate on the North Kingstown ballot received an invitation to the forum.</p><p>However, the Candidates Day forum became a point of contention earlier this month, when concerns were raised about an unaffiliated group of students who formed a political action committee (PAC). The independent group of high school students, called “NKStudents4Candidates,” endorsed several candidates for town council and school committee, all Democrats. However, concerns were raised about the group — including a campaign finance violation and improper use of the school district’s mascot on campaign materials, among others. While NKStudents4Candidates had no part in organizing Candidates Day and were not connected to the school district, some North Kingstown Republican candidates stated ahead of time that the issues cast a negative light on the forum and therefore they would not be participating.</p><p>Candidates in attendance during last Thursday’s virtual forum included those running for school committee, town council, state Senate and even for national office.</p><p>Town council candidates were asked questions regarding additional funding for schools, police reform, solar energy farms, plans for town assets and more.</p><p>In the first segment of the forum, candidate Kevin Maloney (I), a current member of the town council, addressed the NKStudents4Candidates issue, lamenting the process by which they reached their endorsements and the fact that the event would be more heavily geared towards the Democratic candidates’ positions, due to no Republican candidates for town council attending. He added that he was the only town council candidate participating in the forum who was not endorsed by the student group.</p><p>“I do want to applaud the interest in politics that the NKStudents4Candidates have demonstrated,” he said. “However, I would say I wish that they had undergone a more open approach in choosing candidates by reaching out to all of the candidates, interviewing them, listening to rebuttals, before making endorsements.”</p><p>The first question posed was whether candidates would be open to additional funding for safe school reopenings, if it was needed. Earlier this year, after approving the school department’s budget, the town council approved an additional $500,000 for the creation of a Distance Learning Academy in order to accommodate elementary students who would be learning from home.</p><p>Maloney said he would be in favor of additional funding, if necessary.</p><p>“The council was unanimous in the agreement to approve the $500,000 COVID relief funding,” he said. “My colleagues chose to distribute these funds with four equal payments over the entire year and were requesting reports to see how the money was being spent.”</p><p>“I do feel we’re going to need more funding and I would certainly be up to providing some funds,” he added.</p><p>Town council candidate Kimberly Page (D), the former chair of the school committee, also said she would be in favor of additional funding, if necessary, though said it would require assistance from the federal and state level.</p><p>“There is a limited amount of money in the state, and we need more congressional funding for this,” she said.</p><p>Newcomer Jack Kliever (D), during a separate town council candidate segment, also said he would support additional funding.</p><p>“I hope we can do that with existing funds, I think temporary measures make sense, because the pandemic is going to be temporary,” he said.</p><p>Katherine Anderson (D), another newcomer, also agreed, adding that the town council could allocate more funds from its existing fund balance of more than $10 million.</p><p>“If there are indeed cuts to the federal and state aid, as we anticipate there might be, I do support working with the school committee, with our school department, to determine what additional funds might be needed,” she said.</p><p>Current council president Greg Mancini (D), who is running for reelection, said that it was a “very complex question,” adding that any actions had to be done in consideration of the tax rate and potential deficits, as well as state and federal aid. However, he went on to say that the town’s fund balance could be tapped into, if further funding was required.  </p><p>“If need be, we will have to tap into that to make sure we have a safe school system and that our kids are protected,” he said.</p><p>Town council candidate and newcomer Brad Artery (D) said that he had no higher priority than the school system, going on to say that, if elected, his number one goal on the council would be to keep schools safe and running.</p><p>Students also asked candidates whether they would support police reform and, more specifically, if they support cutting police budgets.</p><p>Artery called the concept of “defunding the police” very “shortsighted and reactive,” adding that he did not support it. However, he said that “reform” was more a question of how a police department assesses and trains its staff in regards to systemic bias or racism.</p><p>He said he might support police reform if the town finds that “there are training opportunities and systemic challenges in our department.”</p><p>Mancini also said that “reform and cutting the budget are two different things,” adding that reform was a “complex issue that is more focused on urban areas.” However, like all departments, the police budget would be looked into every year.  </p><p>He also commended the North Kingstown Police Department for attending recent Black Lives Matter protests in town, as well as working with related groups.  </p><p>“They have also engaged with many groups and have gone to protests to make sure everyone was protesting peacefully, my hat’s off to them,” he said.</p><p>Kliever, a former Newport police officer, said that he favored reform but not budget cuts.</p><p>“I have been pleased with the attitude that the NKPD has shown in reaching out to communities that are concerned about the police, about the way police behave,” he said.</p><p>Anderson, a social worker who regularly works firsthand with police for mental health emergencies, said she applauded NKPD for pursuing a grant to have clinicians work them to improve outcomes and safety “for community members and officers alike.” She also commended officers for attending the recent protests.</p><p>She said that the better question would be how to make sure resources are used appropriately so that community members are safe, rather than focusing on budget cuts.</p><p>Page also referenced the grant that would help supply more social workers to go on police calls.</p><p>“I would like to look at more grants and more ways to provide mental health workers and social workers to go with the police,” she said. “I wouldn’t be calling for any sort of cutting support.”</p><p>Maloney said he would support reform, though added that he would want to meet with individuals who have claimed to have been violated by the police department before making any decisions, and determine how often such incidents occur within the town. He also said he wouldn’t support cutting department budgets.</p><p>“I would still need to have some confidence that the problems exist here,” he said. “Over the past eight years, I’ve honestly heard mostly positive things about the department, with maybe one exception.”</p><p>Maloney said he would then try to set up a working group made up of reform supporters, law enforcement and town officials.</p><p>Candidates were also asked if they supported building large-scale solar energy farms in North Kingstown.</p><p>“I do support larger solar energy farms in North Kingstown, when adequately placed,” Maloney said, adding that he was part of the council that restricted large, industrial-type farms in residential zones. “To change zoning where our taxpayers live, and to replace the typically wooded surrounding with these steel structures, is unfair.”</p><p>Page said she supported renewable energy, though added that it needed to be balanced with the residential and rural nature of the town.</p><p>“The large solar farms may not be the way to go about doing that,” she said.</p><p>Kliever said that industrial level solar was “becoming cost effective,” which he said was a good thing, though said that the town shouldn’t be cutting down trees and existing greenery for large-scale solar farms.  </p><p>Anderson echoed Kliever, saying that she would not support an initiative that would involve deforestation or clear-cutting, though she said the town government should look into innovative ways to implement solar and other alternative energy.</p><p>“Certainly I’m in favor of clean energy but I want to protect and preserve our environment as well,” she said.</p><p>Mancini said he was staunchly against large-scale solar farms, though said he supported other means of using alternative energy.</p><p>“I think clearcutting of large swaths of land that are otherwise environmental is a huge mistake,” he said. “I think it takes away from the rural character of our community.”</p><p>Artery said it would depend on where the solar farms are located, and the size of the farms, though said he supported renewable energy.</p><p>“The rural character of our community matters, I certainly want to preserve that,” he said.</p><p>Students then asked town council candidates what their plans were for the “older buildings in Wickford,” particularly the currently vacant Town Hall building and the former Wickford Elementary School, also currently out-of-use. North Kingstown residents approved a $5 million bond referendum for the restoration of the Town Hall building and the return of council chambers, and the council also recently approved a proposal for a developer to transform Wickford El into condominiums.</p><p>While both projects have begun moving forward, with plans for the both currently being drawn up, all the candidates said they would prioritize completion.</p><p>“It’s embarrassing to me as a citizen that [the Town Hall] is uninhabitable,” Artery said. “I do hold previous town councils responsible for not funding that.”</p><p>Mancini also said that, to have Wickford El vacant for 15 years and Town Hall vacant for five, was a “complete dereliction of duty.”</p><p>“I came in two years ago, I started moving the ball forward on both of those, but it takes time,” he said. “The highest priority for us is to get town hall renovated and move forward with the sale of Wickford Elementary School so it is a working asset to the community.”</p><p>Kliever said that the town was also making progress on other projects, including Wickford El and the Town Hall, as well as the sale of the former library, however added that he was concerned about buildings like the old Wilson’s store, which he said “seems to be in limbo.”</p><p>Anderson said that North Kingstown needed a Town Hall that was “inhabitable and functioning and inviting and represents our community.”</p><p>“That is a town asset that was allowed to decay and depreciate for 15 years,” she said. “I think the town council can no longer punt this issue.”</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>In regard to the Town Hall building and the Wickford El sale, Page said it was “time to move ahead.”</p><p>“I’m ready to go,” she said of the Wickford El sale and development proposal. “If we have an architect, let’s make sure we get this job done because we’ve been languishing around.”</p><p>And Maloney said that, while he thought $5 million was too expensive for the renovation of the Town Hall building, the “direction’s already been set.” (The council approved the plans before Maloney was reappointed to the council.)</p><p>“I personally think $5 million for the town council chambers is way too much but the direction’s already been set,” he said.</p><p>Finally, candidates were asked how they would use a hypothetical $1 million grant.</p><p>Maloney said that, while it wouldn’t be enough to cover the costs, he would prioritize either putting the utility poles along Post Road underground or relocating them to the back properties, which he said would clean up the look and spur economic growth in the area.</p><p>Page said she would look for proposals from residents as to how the money should be spent, whether it’s on building repairs, schools or businesses.</p><p>Kliever also said that $1 million “wasn’t what it used to be,” though added that he would use the funds on rehabilitating the old town meeting house.</p><p>Envisioning a scenario where all basic needs are met, Anderson said she would use the grant to help prepare and plan for climate change, such as focusing on parking lots, residential homes, roads and infrastructure.</p><p>Artery said that he would invest further in the education system, which drives better outcomes in a community.</p><p>And Mancini said that, because it would be a one-time grant, he would use it on one-time expenses, with a focus on education.</p><p>Along with candidates for town council, state and federal office, contenders for the North Kingstown School Committee also answered questions from students. Questions touched on funding for the arts program at the high school, the reopening plan, COVID-19 testing and long term plans, among other topics.</p><p>When asked if he supported funding for the arts program at the high school and whether he would support increasing financial support for the theater department, current vice-chair of the school committee Robert Jones (R) said that he first ran for election in 2012 because of the cuts made to the school department’s co-curricular and athletic programs, which he supported.</p><p>“Since 2016, we’ve put over $300,000 into fine arts capital and included in this most current bond a $20,000 request to support it,” he said.</p><p>He also said that he supported making the arts program an enterprise fund, which would provide more funding and transparency.</p><p>Current school committee member Jennifer Hoskins (D), who is also seeking reelection, said that she was also a big supporter of the arts program.</p><p>“For the theater program, we have also discussed at one of the meetings that maybe at some point looking at it as an enterprise fund, and giving them a budget to start with,” she said.  </p><p>Another current member seeking reelection, Jacob Mather (D), echoed Jones and Hoskins in his support for the arts program at North Kingstown.</p><p>“It’s incredible, it’s inspiring, and I highly support that, and I support additional funding where necessary to continue it,” he said.</p><p>Newcomer Jennifer Lima (D) said she was a “strong proponent of funding the music and arts program in North Kingstown,” adding that it was “insane” the theater department didn’t have it’s own budget.</p><p>“I’m definitely all in for increasing financial support for the theater productions,” she continued.</p><p>Candidates were also asked if they supported the school administration’s decision to send high school students back to in-person learning on alternating A/B days of the week, with half of the students attending class in-person on one day and the other half on the second day.</p><p>Lima said that it was necessary to split in-person days in order to keep students safe, while also meeting the departments of health and education’s COVID-19 guidelines.</p><p>“I believe then, and I still do now, that the decision to split the high school in-person attendance in half was the right way to go,” she said.</p><p>Mather, a vocal proponent of full distance learning, said that he felt “very strongly” that a “full in-person return to school would have been reckless and dangerous and financially irresponsible.”</p><p>Hoskins said that she fully supported the administration’s decision to send high school students back on alternating days, especially in light of state and federal guidelines.</p><p>“With the number of students that attend the high school, the only safe way to open any in-person was to do it staggered with an A/B day schedule,” she said.</p><p>Jones said that, while the majority of the committee would have preferred a full, in-person return to schools, he said that the plan was formulated to accommodate high school students as best they could, considering state guidelines around safety.</p><p>Candidates were also asked if they would support mandated COVID-19 tests for high school students, as the University of Rhode Island (URI) recently announced they would be doing.</p><p>However, Jones pointed out that URI was only planning for a two-week window of testing due to a recent spike. Jones teaches at Bryant University, which has a sustained testing plan in place, and he said was “very expensive.”</p><p>The North Kingstown School District has also only had three schools with COVID-19 positive cases, and all of them have been under five cases. Due to the low amount of cases, and the high costs of sustained testing, Jones said he would not be in favor of implementing regular testing.</p><p>“I would not incur that cost,” he said. “I would keep encouraging the protocols we have, and keep going.”</p><p>Hoskins agreed with Jones, adding that the only way sustained testing could be afforded would be through funding from the state.</p><p>Mather said that, while he supported as much testing as possible, the issue came down to availability, costs and resources.  </p><p>Lima said that, while she would support free testing to staff and students on a regular basis, she wasn’t sure about mandating that all students get tested.</p><p> “But we could certainly urge parents to opt in, for the good of the community,” she said.  </p><p>Students also asked whether the new high school sports complex, which was funded through a multi-million dollar bond approved by residents, would be open to students and community members.</p><p>The new track and field complex was recently completed, however, due to COVID-19 restrictions, it has not been made available to the community fully.   </p><p>Lima said that while the complex has been booked up, due to COVID-19 scheduling issues, making it available to community members in the near future was a priority.</p><p>“I think it needs to be accessible to students and community members as much as possible,” she said.</p><p>Mather said he supported using the facility to its fullest potential, but added that the complex was just completed, and that there were still COVID-19 restrictions in place that needed to be abided.</p><p>Hoskins also said that part of the reason the complex was being limited was because of COVID-19 restrictions.</p><p>“I support the administration in what they’re doing to keep the social distancing aspect and the students and community safe as much as possible,” she said.</p><p>And Jones said that, while the committee fully supported transitioning back to the complex being open for public use, there were still state safety guidelines in place that the town had to adhere to.</p><p>“The committee and I fully supported transitioning at some point to where it was before, where it’s open to the public use,” he said. “Remember, these restrictions are not ours, they’re the state’s, for good safety reasons.”</p><p>Candidates were also asked about long term plans to accommodate a growing student population in North Kingstown, particularly elementary students.</p><p>However, Jones said that elementary enrollment was not an issue currently, with most schools at around 80 percent capacity.</p><p>“The right question is what are we doing to be good stewards to make sure that, 20 or 30 years from now, that our infrastructure is postured to support students then,” he said, adding that he presented such a proposal at last week’s school committee meeting.</p><p>Hoskins agreed with Jones that elementary capacity wasn’t necessarily the issue, adding that overall infrastructure plans had to be in place.</p><p>“We need to have a plan so that, 20 or 30 years from now, we have set up the next committees coming up with schools that aren’t falling apart,” she said.</p><p>Mather said improvements to buildings, or even investments in new buildings, had to be made in the next few years.  </p><p>“My hope is that with a growing population, we’ll have a higher tax base, and more appropriated funds to our schools and perhaps making the capital improvements to make this possible,” he said.  </p><p>Lima said that the school district’s long term infrastructure plan needed to be reviewed, particularly Wickford Middle School, which was built in the 1930s.  </p><p>“Diving into reviewing the district needs as a whole, accommodating the growing elementary school population will be incorporated into that,” she said.  </p><p>All candidates thanked the students and school administration for hosting the Candidates Day forum. The general election will take place on Nov. 3.</p><p>To view the full Candidates Day forum, visit the North Kingstown High School website.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline square"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-facebook-f tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Local%20candidates%20talk%20issues%20at%20HS%20forum&url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-twitter tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.ricentral.com/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fab tnt-whatsapp tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.ricentral.com/tncms/asset/editorial/f29f8acc-1d25-11eb-9fdf-bb342737072b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BRICentral.com%5D%20Local%20candidates%20talk%20issues%20at%20HS%20forum&body=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    <i class="fas tnt-square-full tnt-stack-2x"></i>
                    <i class="fas tnt-envelope tnt-stack-1x tnt-inverse"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f29f8acc-1d25-11eb-9fdf-bb342737072b"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                        <i class="fas tnt-print tnt-stack-1x tnt-inverse"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f29f8acc-1d25-11eb-9fdf-bb342737072b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f29f8acc-1d25-11eb-9fdf-bb342737072b" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x tnt-inverse"></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f29f8acc-1d25-11eb-9fdf-bb342737072b" class="save-list-f29f8acc-1d25-11eb-9fdf-bb342737072b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f29f8acc-1d25-11eb-9fdf-bb342737072b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22town%20council%22#tncms-source=keyword" class="tag-town-council label label-default" data-tncms-track-dmp='search: town-council'>Town Council</a>
            </li> <li>
                <a href="/search/?k=%22kevin%20maloney%22#tncms-source=keyword" class="tag-kevin-maloney label label-default" data-tncms-track-dmp='search: kevin-maloney'>Kevin Maloney</a>
            </li> <li>
                <a href="/search/?k=%22candidate%22#tncms-source=keyword" class="tag-candidate label label-default" data-tncms-track-dmp='search: candidate'>Candidate</a>
            </li> <li>
                <a href="/search/?k=%22finance%22#tncms-source=keyword" class="tag-finance label label-default" data-tncms-track-dmp='search: finance'>Finance</a>
            </li> <li>
                <a href="/search/?k=%22politics%22#tncms-source=keyword" class="tag-politics label label-default" data-tncms-track-dmp='search: politics'>Politics</a>
            </li> <li>
                <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics'>Economics</a>
            </li> <li>
                <a href="/search/?k=%22student%22#tncms-source=keyword" class="tag-student label label-default" data-tncms-track-dmp='search: student'>Student</a>
            </li> <li>
                <a href="/search/?k=%22funding%22#tncms-source=keyword" class="tag-funding label label-default" data-tncms-track-dmp='search: funding'>Funding</a>
            </li> <li>
                <a href="/search/?k=%22high%20school%22#tncms-source=keyword" class="tag-high-school label label-default" data-tncms-track-dmp='search: high-school'>High School</a>
            </li> <li>
                <a href="/search/?k=%22kimberly%20page%22#tncms-source=keyword" class="tag-kimberly-page label label-default" data-tncms-track-dmp='search: kimberly-page'>Kimberly Page</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-3bbf3f36-23b4-11e8-a905-5cb9017b3617">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.ricentral.com/users/profile/Alex%20Trubia" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Alex Trubia"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://secure.gravatar.com/avatar/d61087778ddece8ac5bbf81ae4e43f3b?d=mm&r=g"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.ricentral.com/users/profile/Alex%20Trubia" rel="author" class="tnt-user-profile-link tnt-user-name">Alex Trubia</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:atrubia@ricentral.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        <i class="fas tnt-square-full tnt-stack-2x"></i>
                        <i class="fas tnt-envelope tnt-stack-1x tnt-inverse"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-3bbf3f36-23b4-11e8-a905-5cb9017b3617" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=3bbf3f36-23b4-11e8-a905-5cb9017b3617&amp;s=start_time&amp;sd=desc" data-subject="Alex Trubia" data-description="Whenever Alex Trubia posts new content, you'll get an email delivered to your inbox with a link." data-name="Alex Trubia notification" data-author-id="3bbf3f36-23b4-11e8-a905-5cb9017b3617" data-user-url="https://www.ricentral.com/users/">
        <i class="fas tnt-star"></i> Follow Alex Trubia
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.ricentral.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.ricentral.com/users/login/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.ricentral.com/users/signup/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-728706" class="tncms-block"><section id="block-728706" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-728706 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-728706" class="card-grid-behavioral card-grid card-img-"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-728706" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="f29f8acc-1d25-11eb-9fdf-bb342737072b" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/nk_standard_times/news/local_news/local-candidates-talk-issues-at-hs-forum/article_f29f8acc-1d25-11eb-9fdf-bb342737072b.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="f29f8acc-1d25-11eb-9fdf-bb342737072b" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.ricentral.com/users/login/?referer_url=https%3A%2F%2Fwww.ricentral.com%2Fnk_standard_times%2Fnews%2Flocal_news%2Flocal-candidates-talk-issues-at-hs-forum%2Farticle_f29f8acc-1d25-11eb-9fdf-bb342737072b.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-774870" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-774870" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-774870');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-603034" class="tncms-block"><section id="block-603034" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-603034 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-603034" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-603034" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-603034" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-603034" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-603034" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/kent_county_daily_times/meet-the-candidates-kimberly-shockley-dist-5-coventry-town-council/article_acf6eb5a-19e2-11eb-933b-3b082b923e20.html">Meet the candidates: Kimberly Shockley, Dist. 5 Coventry Town Council</a></li><li><a href="/narragansett_times/narragansett-town-council-approves-beach-fee-increases/article_3fc6aea6-189f-11eb-ac90-83ac4c74a625.html">Narragansett Town Council approves beach fee increases</a></li><li><a href="/nk_standard_times/news/local_news/nk-town-council-meeting-ends-abruptly/article_dc8c406a-1d23-11eb-bb1c-df4930a6a893.html">NK Town Council meeting ends abruptly</a></li><li><a href="/narragansett_times/narragansett-town-council-election-profile-susan-cicilline-buonanno/article_4cfd43d0-18a6-11eb-928f-271249986e28.html">Narragansett Town Council election profile: Susan Cicilline Buonanno</a></li><li><a href="/kent_county_daily_times/thundermist-w-w-hez-distribute-hundreds-of-covid-protection-kits/article_5a4f7d50-185b-11eb-9803-73f493cd774f.html">Thundermist, W.W. HEZ distribute hundreds of COVID-protection kits</a></li><li><a href="/narragansett_times/narragansett-library-board-appointments-prove-contentious/article_8378bfae-189f-11eb-be86-4b4d38eac105.html">Narragansett Library Board appointments prove contentious</a></li><li><a href="/nk_standard_times/news/local_news/exeter-tables-preserve-at-rolling-greens-discussion/article_077774fe-1241-11eb-bb06-e7e2a8718cb1.html">Exeter tables Preserve at Rolling Greens discussion</a></li><li><a href="/news/law_and_order/east-greenwich-police-logs-oct-29/article_cebe7566-1d1e-11eb-94eb-db9ee842fcbf.html">East Greenwich Police Logs Oct. 29</a></li><li><a href="/narragansett_times/bob-lancia-is-challenging-jim-langevin-in-ris-2nd-congressional-district/article_4a2164ce-0f24-11eb-b573-738fd1d61004.html">Bob Lancia is challenging Jim Langevin in RI's 2nd Congressional District</a></li><li><a href="/kent_county_daily_times/t-bonz-grill-set-to-open-in-coventry-next-month/article_6077dd4a-1391-11eb-aebc-d7581faef4e4.html">T-Bonz Grill set to open in Coventry next month</a></li></ul></div>
        
        
            <div id="images-603034" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/meet-the-candidates-jennifer-ludwig-dist-2-coventry-town-council/image_4ea6e778-1463-11eb-ae2b-7bbe7b35d59c.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Meet the candidates: Jennifer Ludwig, Dist. 2 Coventry Town Council"
                            class="img-responsive lazyload full default"
                            width="634"
                            height="634"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/assets/v3/editorial/4/ea/4ea6e778-1463-11eb-ae2b-7bbe7b35d59c/5f917d2992c72.image.jpg?crop=634%2C634%2C0%2C61&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/meet-the-candidates-bradford-mayer-dist-2-coventry-town-council/image_ae7aa5cc-1463-11eb-9c10-53ef01b9c572.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Meet the candidates: Bradford Mayer, Dist. 2 Coventry Town Council"
                            class="img-responsive lazyload full default"
                            width="1287"
                            height="1287"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/assets/v3/editorial/a/e7/ae7aa5cc-1463-11eb-9c10-53ef01b9c572/5f917e09f3b24.image.jpg?crop=1287%2C1287%2C0%2C161&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/t-bonz-grill-set-to-open-in-coventry-next-month/image_7af279b4-1391-11eb-9259-930c64b4ce77.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="T-Bonz Grill set to open in Coventry next month"
                            class="img-responsive lazyload full default"
                            width="1281"
                            height="1281"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/assets/v3/editorial/7/af/7af279b4-1391-11eb-9259-930c64b4ce77/5f901d18635df.image.jpg?crop=1281%2C1281%2C0%2C167&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/meet-the-candidates-debra-bacon-dist-5-coventry-town-council/image_1320e09e-19e2-11eb-acfe-7f50456d157e.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Meet the candidates: Debra Bacon, Dist. 5 Coventry Town Council"
                            class="img-responsive lazyload full default"
                            width="232"
                            height="232"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/assets/v3/editorial/1/32/1320e09e-19e2-11eb-acfe-7f50456d157e/5f9ab53a78bd6.image.jpg?crop=232%2C232%2C0%2C59&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-603034" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-603034" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/kent_county_daily_times/coventry-park-dedicated-to-wwi-veterans-frequently-targeted-by-vandals/article_23b50dd6-0d53-11eb-83f5-67c703de5396.html">Coventry park dedicated to WWI veterans frequently targeted by vandals</a> (1)</li><li><a href="/east_greenwich_pendulum/news/local_news/official-state-name-could-change-after-election-day/article_a787dc30-1d1e-11eb-9890-37b1afa8e3e1.html">Official state name could change after Election Day</a> (1)</li><li><a href="/letters_to_the_editor/linking-plantation-with-slavery-in-rhode-island-could-wipe-out-the-accomplishments-of-the-founders/article_c9c5767e-072d-11eb-83b1-dbde726f3a36.html">Linking ‘plantation’ with slavery in Rhode Island could wipe out the accomplishments of the founders</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-603035" class="tncms-block"></div></div>

    <div class="tout-sdk tout-right-rail-embed"></div>  
     
       <div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-603041" class="tncms-block"><section id="block-603041" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-603041 ">
        <div class="block-title-inner">
            <h4>
                
                Newsletters
                
            </h4>
        </div>
    </div></div><div class=""><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        
            <div class="mailinglist-container">
                <div class="form-group ">
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">ricentral.com daily headlines</h4>
                            
                                <p>Would you like to receive our daily news? <strong>Signup today!</strong></p>
                            
                        </div>
                    
                </div>
                <div class="form-group">
                    <a href="https://www.ricentral.com/users/admin/mailinglist/" class="btn btn-default btn-block">Manage your lists</a>
                </div>
            </div>
        
    </div></div></section></div><div id="tncms-block-603040" class="tncms-block"></div><div id="tncms-block-774871" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-774871" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-774871');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-603038" class="tncms-block remove-margin"><section id="block-603038" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-603038 ">
        <div class="block-title-inner">
            <h3>
                
                SRI’s Friends To Follow
                
            </h3>
        </div>
    </div></div></section></div><div id="tncms-block-507733" class="tncms-block"><div id="f2f_widget_3274304242"></div>
<script type="text/javascript">
	var f2f = {
	    width: '100%',
	    height: '425',
	    clickTag: '',
	    cacheBuster: ''
	};
	(function() {
	var i = document.createElement('iframe'),
	    w = document.getElementById('f2f_widget_3274304242');
	i.src = 'https://yumasun.friends2follow.com/f2f/widget/async/socialstack/1238/0/12/140/1/1/1/9/9/0' + 
	'?click=' + (f2f.clickTag.length > 0 ? encodeURIComponent(f2f.clickTag) : '') +
	'&cache=' + (f2f.cacheBuster.length > 0 ? f2f.cacheBuster : ''),
	i.width = f2f.width, i.height = f2f.height, i.scrolling = 'no', i.frameBorder = 0;
	w.appendChild(i);
	})();
</script></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-603042" class="tncms-block"><div id="UbW43FT8xtbpsGLfQ10nxBFYjbqyf-V2r7dDf9Gm"></div>

<script src="https://s.newsmaxfeednetwork.com/static/js/connectV5.js"></script>
<script type="text/javascript">
    NM.init({
        widgetId: "UbW43FT8xtbpsGLfQ10nxBFYjbqyf-V2r7dDf9Gm",
         template: "NM07"
    });

</script>
</div><div id="tncms-block-603044" class="tncms-block"><section id="block-603044" class="block emphasis-h3   " ><div id="html-asset-603044">
            <div class="html-content"><script src="http://business.ricentral.com/ricentral/widget:snapshot?Output=JS"></script></div>
        </div></section></div><div id="tncms-block-603046" class="tncms-block visible-xs"><section id="block-603046" class="block emphasis-h3   " ><div id="html-asset-603046">
            <div class="html-content"><div id="ym_2001059" class="ym"></div><script type="text/javascript">(function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.m6.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);</script>
</div>
        </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    
    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-603003" class="tncms-block"><section id="block-603003" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-603003 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-home"  href="/nk_standard_times/" >
                    <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/nk_standard_times/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/nk_standard_times/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/nk_standard_times/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="http://oceanstatemarketplace.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-one-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-603013" class="tncms-block"><section id="block-603013" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-603013 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html/" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html/" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-personnel"  href="/site/personnel.html" >
                    <span class="nav-label">Personnel</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscription-services"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-site-forms"  href="/site/forms/" >
                    <span class="nav-label">Site Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-two-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-603006" class="tncms-block"><section id="block-603006" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-603006 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-603012" class="tncms-block padding-bottom"><section id="block-603012" class="block emphasis-h3   " ><div class="block"><a href="/nk_standard_times/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png?resize=200%2C36 200w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png?resize=300%2C54 300w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png?resize=400%2C72 400w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png?resize=540%2C98 540w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png?resize=750%2C136 750w, https://bloximages.newyork1.vip.townnews.com/ricentral.com/content/tncms/custom/image/5bb13ca0-0552-11e5-8c20-636589eeeec1.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-603005" class="tncms-block"><section id="block-603005" class="block emphasis-h4   " ><address>
    <strong>ricentral.com</strong><br>
    187 Main Street <br>
    Wakefield, RI 02879
    <br>
    
        <strong>Phone:</strong> 401-789-9744<br>
        <strong>Email:</strong> <a href="mailto:info@ricentral.com">info@ricentral.com</a><br>
    
</address></section></div></div>
        
        <div id="tncms-region-footer-col-three-under" class="tncms-region "></div>
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "><div id="tncms-block-603002" class="tncms-block visible-xs"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.ricentral.com",
  secureDomain: "ricentral.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-block-mobile-footer1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-mobile-footer","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/ricentral.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-603015" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-603015"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">RICentral.com</a>, 187 Main Street  Wakefield, RI</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("f29f8acc-1d25-11eb-9fdf-bb342737072b")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc13855.add('act', dmpData);
	_cc13855.bcp();

            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script src="https://bloximages.newyork1.vip.townnews.com/ricentral.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script>/*<![CDATA[*/ $('.mailing-lists input:checked').each(function(){
        var mailListData = 'is_maillist_subscriber: ' + $(this).val();	_cc13855.add('act', mailListData);
	_cc13855.bcp();
}); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                            /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc13855.add('act', dmpData);
	_cc13855.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>